1

Closed

NuGet GeoAPI won't install with Xamarin

description

It works via source but NuGet will not install:

Installing 'GeoAPI 1.7.2'.
Successfully installed 'GeoAPI 1.7.2'.
Adding 'GeoAPI 1.7.2' to MinefieldManagement.
Uninstalling 'GeoAPI 1.7.2'.
Successfully uninstalled 'GeoAPI 1.7.2'.
Install failed. Rolling back...
Could not install package 'GeoAPI 1.7.2'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v4.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.
Closed Aug 27, 2014 at 6:08 AM by D_Guidi
website closed

comments

FObermaier wrote May 14, 2014 at 6:21 AM

The NuGet packages have not been released for the PCL version

jkara wrote May 14, 2014 at 1:50 PM

That explains it! Is there a plan to release the PCL versions?

FObermaier wrote May 15, 2014 at 5:50 AM

I'm not consent with [DataContract]/[DataMember] instead of [Serializable].
Do you need some sort of (De-)Serialization provided by GeoAPI/NTS

wrote Aug 27, 2014 at 6:08 AM